Apr 10, 2012 @ 12:36 am

Hello. I am getting the same error message. "You can't change the startup disk to the selected disk. The bless tool was unable to set the current boot disk." I have a 128 and 256 SSD installed in my MacBook Pro. Originally I had the 265 SSD as the main drive and a 750 HDD installed via an opti-drive replacement kit. I cloned the 265 SSD on to the 750 HDD removed that disc and moved and copied it to the 128 SSD on another laptop, after which, Both discs appeared as bootable options in System Preferences. I didn't actually try booting from the 128 SSD but the 750 worked fine.

I then put the 128 SSD into the opti-drive so I have Identical bootable discs in the laptop. Both discs appear as bootable on start-up but only the SSD 256 actually works. There is also an option for "Recovery Disc" on start-up. Both discs appear in system preferences as possible start-up discs but when I try to boot from the 128, I get the error message mentioned above. I am running Lion 10.7.3 MacBook Pro 2.3 GHz Intel Core i7, 16 GB 1333 MHz DDR3.

I've noticed that I cannot save anything on the SSD 128 I considered reformatting it and cloning the SSD 256 back to the 128 but that would put me back at the same place that I am currently at, so I wasn't sure what I should do next.

I am trying to switch the drives because I wanted to use the smaller 128 to run the OS and applications and use the larger SSD exclusively for editing video and other media.

Thanks in advance for your help.

1 Posted by Mike Bombich on Apr 9, 2012 @ 8:57 pm

Hi Jeremy:

I think this is slightly different from Laurie's issue. I have seen this one reported a few times, some people have trouble getting disks to boot from the OptiBay device, e.g.: [LINK NO LONGER EXISTS] [LINK NO LONGER EXISTS]

In that second discussion the OptiBay vendor (OWC in that case) suggested swapping the two hard drives so the newer hard drive was in the standard slot and the previous hard drive was in the OptiBay. You might give that a shot.

I've noticed that I cannot save anything on the SSD 128

This is probably the underlying problem. When you attempt to set the startup disk, the Startup Disk Preference Pane (the bless tool, actually) will attempt to update the volume header to indicate the location of the system folder. If it can't make this modification, you'll get the error that you saw. Reformatting the disk may also resolve the problem.


2 Posted by Jeremy on Apr 10, 2012 @ 5:31 am

Hi MIke. Thanks for the quick reply. I figured out the problem, as described from the Tech at MCE, "What is happening is that there is an issue with Apple's implementation of SATA-III (6gbps) in the optical bay S-ATA port which is where the OptiBay connects to. There is no problem in the main hard drive bay which is why the Samsung SSD works there." Thought I would add his response in case any others are dealing with the same problem. Thanks again for your quick reply. Jeremy