Having finished a backup task (launches if connecting a specific firewire disk) waking up the system leads to a total system freeze

Aug 7, 2011 @ 6:31 pm

I have been using CCC for a long time to conduct a backup task whenever I connect my backup disk to the system. Up to CCC 3.4 all worked always fine. As of the new CCC, I get each time a very bad system freeze. The sequence is: CCC finished successfully its backup task. Since I do avoid working on my system during such a back up, the system enters sleep mode. When I return to the machine and wake it up, it first seems normal, however, it becomes difficult to switch applications, the cursor changes into a spinning beach-ball and soon everything freezes up totally. Though I can still move the cursor with the mouse, no menu can be used anymore, no keyboard command works (force quite panel can't be launched) and the only remedy is pressing the power button till the machine shuts down. Very bad. My system (Mac OS 10.6.7), is very well maintained and works otherwise flawlessly (checked disks, repaired permissions etc., all software in mint condition or it gets thrown out). This freeze takes place each time CCC does its backup and was the case from the first 3.4 version onwards. I have 2 partitions on my Mac, and the external disk exactly mirrors that and also has two partitions of same size (a total of 500 GB each, on startup volume HDX->HdXBU ~49GB free, on 2nd volume HD2 4.3 GB free). An excerpt from the CCC log

        Special files: 53
     Hard links: 4748
     Extended attributes (modified): 1585114 (61.90 KB)
     (Unmodified extended attributes are not enumerated)

08/07 19:57:12  Time elapsed: 00:19:55. Data copied: 1.26 GB

08/07 19:57:12  HDX BU Task: This task is not scheduled to run on a scheduled interval. Will run next when the source ("/") or destination ("/Volumes/HDXBU 1") volume is reconnected.
08/07 19:57:12  HDX BU Task: Unmounting the destination volume "/Volumes/HDXBU 1"...
08/07 20:02:02  The system is about to sleep. No tasks are running, so I'm not dissenting.
08/07 20:02:02  The system is about to sleep. No tasks are running, so I'm not dissenting.
08/07 20:02:02  CCC received a non-abortable sleep notification.
08/07 20:02:02  CCC received a non-abortable sleep notification.
08/07 20:02:44  Wake from sleep
08/07 20:02:44  Wake from sleep
--  Here the system freeze occurred -- (my insertion into log)
08/07 20:04:12  System just restarted, will wait for 80 seconds to let the system settle down...

I was hoping the updates would fix this, but that seems not to be the case. I will downgrade to CCC 3.3.7 till this issue is resolved, since I fear system corruptions with a regular system freeze I for sure cause with CCC 3.4.x.

Thanks for any advice.
Andreas Fischlin

P.S.: I have on purpose not upgraded to 10.6.8 because of the bad reviews and pdf hassle I encountered with 10.6.6->10.6.7.
Main characteristics of my Mac: Hardware Overview:

Model Name: MacBook Pro Model Identifier: MacBookPro6,1 Processor Name: Intel Core i7 Processor Speed: 2.66 GHz Number Of Processors: 1 Total Number Of Cores: 2 L2 Cache (per core): 256 KB L3 Cache: 4 MB Memory: 8 GB Processor Interconnect Speed: 4.8 GT/s Boot ROM Version: MBP61.0057.B0C SMC Version (system): 1.57f17 Serial Number (system): C02CN68TDC7C Hardware UUID: 83BEDA21-1A79-5526-B48F-431800EBA724 Sudden Motion Sensor: State: Enabled

500 GB SSD, 2 partitions (HDX 448.52GB, HD2 46.97GB) + MobileMe iDisk

1 Posted by andreas.fischlin on Aug 7, 2011 @ 2:38 pm

Sorry for the poorly formatted log. I think I better attach the entire log of CCC (/Logs/CCC.log).

2 Posted by andreas.fischlin on Aug 8, 2011 @ 4:49 am

I managed to downgrade to CCC 3.3.7, but it was adventurous and I got system freezes all the time. This time not only at the end of a backup task and wake up from sleep, but also in the middle of a running backup task. I also got several system freezes during my attempts to delete the tasks using CCC 3.3.7. E.g. the following alert was shown during such an attempt to delete the task:
___________________ Attempt to delete scheduled tasks result in alert:

An unknown error occurred while starting the privileged task helper tool.

Would you like to (re)install the tool and try again?

___________________ Note, I had the system up in safe boot mode while this happened. At least in safe boot mode it was otherwise straightforward to delete the tasks, i.e. no system freezes occurred. I attach once more the CCC log file. Note, the CrashReporter shows no entries that relate to CCC nor any other process on the time of the many system freezes I encountered. I also attach the system.log filtered for CCC (system.log-Filtered for CCC.log) and the entire system.log showing many entries, in particular from one hang where Mail was running.

Conclusion: Going back to CCC 3.3.7 did not help at all and I give now up on this backup method and I finally managed to delete all theses tasks despite the encountered system freezes. Now, that I have got rid of the tasks for good, I can reconnect the external disk without the backup tasks being launched and then getting anymore system freezes. There seems to be no remedy than to "resort" to manual backups, I guess I can resume 3.4.2 without risking much.

3 Posted by Mike Bombich on Aug 9, 2011 @ 4:21 pm

Hi Andreas:

Sorry for the delay. I suspect hardware problems are at play, that's usually the result when we see things like this in the CCC log:

08/08 10:00:53 [INFO] Volume unmounted: "/Volumes/HDXBU 1"
08/08 10:00:53 Aborting clone, target disk has disappeared
08/08 10:00:53 0.00 KB [Please see ... for a comment about this figure]


08/08 10:00:53 Initiating synchronization engine...
08/08 10:00:53 [INFO] Volume unmounted: "/Volumes/HDXBU 1"
08/08 10:00:54 Building a list of items to be considered for backup


08/08 10:00:54 Aborting clone, target disk has disappeared
08/08 10:00:54 [INFO] Volume unmounted: "/Volumes/HD2BU"

Those two volumes are both on the hard drive in your Lacie Firewire enclosure. I'd recommend this set of troubleshooting steps:

Troubleshooting hardware problems

Adding this to the beginning:

  1. Disable both of the backup tasks
  2. Mount both backup volumes
  3. Enable one of the backup tasks and run it manually

Run the second task manually if the first one succeeds, then try running them both at the same time to see if the error occurs again.


4 Posted by andreas.fischlin on Aug 10, 2011 @ 8:27 am

Dear Mike,

First many thanks for your prompt reply (given your workload, I was happy to receive it that quickly). Indeed, it seems you are right on. Unfortunately the situation is a bit tricky. I did all tests (Disk Utility etc.) including hardware tests of my machine, and no faults can be detected. Yet, evidence is clear, since I use not only CCC for a backup, but also Synchronize Pro to extract work files onto another external firewire 400/800/USB drive. Running my Synchronize Pro scripts, I get the same system freezes as soon as a file should get copied to that other external disk! I get them also when I use the slower USB connection to the same drives instead of the FireWire 800. I also get them when I use the FireWire 400 connection, other cables, all the works as you describe them on your website (Troubleshooting hardware problems). I do not believe that both external disks should have gone bad at the same time. Therefore I suspect something between my logic board (being ok according to the hardware tests) and external disks. Backing up to a network volume fortunately works and without any external disk attached my system works flawlessly.

To sum up: Thanks for the excellent diagnosis Mike, it is not a CCC problem, on the contrary, CCC did for weeks a better job in being able to copy files than Synchronize Pro. However, I still don't know what is really wrong, since not even the hardware test found a flaw in my system, yet trying to copy a file to an external hard disk freezes my system in quite an ugly, worrisome manner. Will seek advice from hardware specialists.

Sincerely yours,
Andreas Fischlin

5 Posted by andreas.fischlin on Aug 14, 2011 @ 9:51 am

I am sorry, but I have to come back to this issue, since the conclusions drawn were wrong (and the issue is far from being resolved and the prevailing problem is a very nasty one). I wish to add following observations: There can't be any hardware problems, it is all software problems only, since all my tests for hardware problems showed there is nothing wrong with any of the hardware components involved and more importantly, I can connect any external disk and work with it in safe boot mode, whereas in normal boot mode I can no longer connect any external disk without getting a system freeze, regardless of the cable I use, regardless of the port I use (firewire 400, 800, USB), regardless of the external disk drive (I used several, well tested ones), using other users on the same system, all these variations make no difference etc. Let me abbreviate this problem with EDHUL2SF (External Disk Hook Up Leads To a System Freeze). EDHUL2SF is fully reproducible: I need only to connect an external disk and about half a minute later I have a system freeze (BTW, I have now of course deleted the automatic CCC back-up tasks I described earlier).

Why do I bring this up once more (reopen the discussion): I went back to the actual log files involved when I made the transition from CCC 3.3.7 to CCC 3.4, now attached). They clearly show that I made every day backups up to the point where I upgraded to 3.4. Up to that point I have never encountered DHUL2SF. I do not remember having made any other changes on my system during that period than to upgrade to CCC 3.4. The attached log shows that the DHUL2SF was immediately there after using CCC 3.4 for the first time. I suspect now that DHUL2SF is due to a corruption of my system software (not user specific) and consider it very likely that the upgrade to CCC 3.4 corrupted my system.

Dear Mike, let me therefore ask following questions:

  • Do you agree with my reasoning or do you see there a flaw? There was a spill-over of the CCC logs that I first overlooked and report on now for the first time (note, I've cut out about 95% of the log entries from 'CCC.0.log', since I believe them to be useless. Those entries come from the first uses of CCC 3.4, filling up the log quickly with similar messages and then reaching the 6 MB limit; I documented of course clearly where I did modify the 'CCC.0.log').

  • What could the corrupted system component be? Note, I made in the mean-time an upgrade to Mac OS X 10.6.8 v1.1 using the Combo update (I have nothing to lose anymore). Unfortunately this upgrade from 10.6.7 to 10.6.8 v1.1 makes no difference and DHUL2SF is still with me.

  • Any ideas or hints you could offer with your large knowledge on how to further track down the cause of this problem? I hate having to reinstall the OS X, since that takes me typically a week of work till all my sophisticated work flow is all up and running reliably again.

Thanks for your help and cooperation.

Sincerely yours,
Andreas Fischlin

6 Posted by baltwo on Aug 14, 2011 @ 7:07 pm

Step one is to create a new admin user account, log into it normally, and see if the issue persists.

7 Posted by andreas.fischlin on Aug 15, 2011 @ 7:41 am

I already reported that I have done that and that the problem has persisted. See previous report.


8 Posted by Mike Bombich on Aug 16, 2011 @ 10:19 am

Hi Andreas:

I don't disagree with your thought process, we can certainly continue to troubleshoot this. If you think the issue is a regression in CCC 3.4.x, you can try running CCC 3.3.7 again to see if the issue recurs there as well. You can get 3.3.7 here:


Another thing you can try that is comparable to a clean install is to install Mac OS X onto one of the extra external hard drives that you have. Then boot from that hard drive and try running CCC. If that works, then you can conclude both that 1) The external hard drive connection is fine and 2) that an OS issue is causing the problem. If it doesn't work, unfortunately you can't conclude anything (and I would recommend a clean OS install if the issue occurs with 3.3.7).


9 Posted by andreas.fischlin on Aug 17, 2011 @ 4:58 am

Dear Mike,

Many thanks for your advice. I already tried all these options and found out that the problem DHUL2SF persisted also with CCC 3.3.7. Therefore I concluded that there was some permanent change/damage done to my system and even suspected CCC 3.4.x. As I learned later, it is probably just a change of some other software component (see below).

Because DHUL2SF was entirely absent whenever I booted into safe mode, I have investigated all agents/daemons in

- '/Library/LaunchAgents'

- '/Library/LaunchDaemons'

BTW, booting into safe mode was actually the only way I could remove the tasks of CCC that happened in the end to immediately cause a system freeze as soon as I connected any external disk. And BTW there may be a bug in CCC 3.4.2 when managing tasks in safe boot mode. At least I get each time an error alert, I do not understand.

I simply and brutally removed all the files from above listed two folders, made a restart and indeed never a DHUL2SF. Thus I could narrow down the possible cause by fully deinstalling all those applications that have made an entry in any of those two folders. They were


- Logitech Control Centre (LCC)

- Little Snitch

- Sophos (Antivirus protection software)

It turned out, after tedious time-consuming testing, including irreparably corrupting one large 2 TB external disk (!) and therfore disk salvaging etc., that probably Sophos was/is the cause of all this havoc. I concluded this also by encountering DHUL2SF while having booted from an external 10.6.4 OS X system. That had also Sophos installed and the inevitable automatic update took place shortly after the booting. I believe this corrupted also that otherwise little customized system, BTW a system that I first considered of using as the starting point for building a new one, fearing my latest 10.6.7 was completely corrupted.

As I explained earlier I was mislead by having actively changed only CCC (3.3.7 to 3.4, for sure no other changes on my software/system done by me actively, first on purpose no upgrade to 10.6.8) and DHUL2SF was there persistently at the end of CCC 3.4, CCC 3.4.1, CCC 3.4.2 backup tasks, each time, fully reproducible System freeze. However, Sophos makes virus updates automatically daily, also of itself. It was perhaps coincidence that Sophos introduced this DHUL2SF problem around the date when I made also the transition from CCC 3.3.7 to 3.4 .

I suspect now an incompatibility between waking up from sleep while having external disks connected and the latest Sophos. Deinstalling Sophos, I never got DHUL2SF. Reinstalling Sophos and allowing it to update, I get DHUL2SF every time I use CCC, regardless whether it is CCC 3.3.7 or 3.4.2. Therefore no damaged files, no damaged Sophos, no damaged OS X system component. My current explanation is: Sophos has never caused any problems for years, but now it does. :-(

I will have to further seek advice from my university and security specialists what could be possibly done on this issue, since Sophos is a recommended anti virus software at my institution.

Once again, Mike: First many thanks for CCC and many thanks for all the thinking with me and the advice offered. Very helpful and I am very grateful.


10 Posted by Mike Bombich on Aug 17, 2011 @ 2:02 pm
And BTW there may be a bug in CCC 3.4.2 when managing tasks in safe boot mode. At least I get each time an error alert, I do not understand.

The dialog that you're seeing is a result of being booted in Safe Mode. The purpose of Safe Boot mode is to disable third-party components, so CCC has to ask your permission to load the privileged task helper tool.

In regards to your Sophos issue, that's actually documented:

Antivirus software may interfere with a backup

I will add this discussion to that list as well, I'm glad you were able to track down the issue!


11 Posted by andreas.fischlin on Aug 17, 2011 @ 3:58 pm

Dear Mike,

Thanks for the hint. But what was documented there is not quite the same, but it is certainly good you added the link to this discussion.

Remember, my backup tasks using CCC first completed successfully and the first system freezes occurred only when waking up the machine from sleep.

On the other hand, yes, later unmounting or mountpoint changes occurred in the middle of CCC backups as you found out studying my logs. This clearly disrupted CCC backup tasks and I encountered at that time also system freezes in the middle of CCC backups.

Finally, during the peak days of the problem, all I needed was connecting an external disk (usb, firewire, whatever), no need to start CCC or doing anything at all on the machine, and I got a system freeze (and CCC was then not involved at all, since I had deleted those CCC tasks that launched a CCC backup as I did for months before).